Attribute Phone doesn't work

I configured a listing Atribute with type “phone” and country code CA.
When I create a listing and entering phone number with only numbers, it saved nicely for me.
But when I try editing the same listing, e.g. Title, and then try to save the change, it stopped me alerting that phone number doesn’t match defined format.

Then I noticed that it automatically added “-” in the phone number.
I had to delete those “-” before I can save changes.

Steps to reproduce

  1. Create a listing attribute with field type “phone” and country “CA”.
  2. Create a listing and fill in phone number with only numbers. and Save.
  3. Come back to the same listing and make any changes to any other fileds e.g. Title.
  4. Save the change.

Actual result

System stops you saving changes and ask you to change phone number format.

Expected result

Save changes successfully

Extra details

I can save changes if I delete those "-"s that was automatically added to my phone number by the system.

Please make sure that you have the latest HivePress version.

Please disable third-party plugins and customizations (if there are any) and check if this issue persists. If you use a caching plugin (e.g. LiteSpeed), make sure that caching is disabled for logged-in users.

If the issue persists please send temporary WP access via email to support@hivepress.io with a link to this topic and any extra details that may help detect this issue, and we’ll check it. You can send a temporary admin access link using this plugin Temporary Login Without Password – WordPress plugin | WordPress.org