Blocking of slots in the listing calendar for multiple days

Hi Ihor,

Customers have told me that blocking slots in the calendar does not work correctly. Indeed, when we make a multiple selection of slots with a click and drag and then click on the padlock to block these slots for reservation, well only the slots of the first day are blocked. For other selected slots on the following days, reservation is still possible despite the red indication in the calendar.



calendar3

I have already tried to deactivate all the plugins but the bug is still present. I also tried to upgrade the FullCalendar library to version 6.1.11, but the problem remains, the bug must be elsewhere.

All that remains is the Hivepress installation in the latest version on my Debian 12.5 with Apache in version 2.4.57, PHP 8.2.7 and MySQL in v15.1.

The different web browsers tested are as follows:
Firefox 126.0
Chrome 125.0.6422.61
Edge 125.0.2535.51

Thanks in advance

Hi,

We checked this issue from our side, and it seems okay. Please disable third-party plugins and customizations (if there are any) and check if this issue persists. If you use a caching plugin, make sure that caching is disabled for logged-in users. Also, caching is possible on the part of the hosting provider, check the host settings additionally. If this issue exists, please send temporary WP access to support@hivepress.io with details for reproducing this issue, and we’ll check it (please send only the link, without login and password). You can create a temporary access link using this plugin Temporary Login Without Password – WordPress plugin | WordPress.org.

Hi,
I had already disabled third-party plugins and customizations in my various tests. The cache plugin was also disabled.
I’m sending you an email to give you access so you can see the problem.

Thanks

Hi,

If you purchased a theme or extension, please enter the license key in the forum profile settings, this will enable the Premium Support badge and ensure a 24-hour turnaround time.

Hi,

I already have a license keys entered in Profile on the forum, is it not correct?

The key is correct, thank you. Regarding your site, it shows that it is live, let us know if we can disable all third-party plugins, we need it for testing.

Hi,

Okay, that reassures me. Yes, you can of course, this is a testing environment for this subdomain.
Thank you

Hi,

We have checked your site and for some reason, there is a critical error displayed on it, please check your settings or PHP logs: How to configure WordPress error logs to identify and resolve problems - HivePress Help Center

Hi,

I just solved the problem, you had obviously deactivated the hivepress plugin and the functions.php file continued to call certain functions of this extension (like this one: remove_filter( ‘posts_orderby’, [ hivepress()->booking, ‘set_booking_order’ ], 10, 2 );). The info was in the Wordpress logs and not php: debug.log in wp-content.
I saved the original functions.php file as functions.php2, and dumped the contents of functions.php.
You can continue your research.

Hi,

We have disabled all third-party plugins and blocked time slots in the calendar, and after testing, the time slots are successfully blocked and not displayed for selection on the frontend. Please note that we tested this on the “Salle d’escalade sur Bourges listing”. Try logging in through an incognito mod in the browser, and without enabling third-party plugins, and test again.

Hi,
No, it still doesn’t work. I tried on several listings, including “Salle d’escalade sur Bourges listing” and only the first day is blocked. The other days selected by clicking and dragging are still not blocked. You will understand that this is not an incompatibility with a third-party plugin. Only the day-by-day blocking method is functional, but this quickly becomes very unpleasant when it comes to blocking the two summer months (July and August) for example.

As a reminder, a host connects and goes to the calendar in their listing and clicks and drags several dates before clicking on the padlock to block.

Then, the client goes to the listing and when viewing the dates, the first day clicked and dragged by the host is blocked but not the others.

As you can see, I am in private browsing during my tests.

Waiting for your answer

Hi,

Please provide a screencast of this issue, showing the steps step by step, so that we can reproduce the issue on our side.

Hi,

Of course, here it is:

https://recette.opyk.fr/2024-06-02_22-40-42.mp4

Hi,

Please send temporary WP access to support@hivepress.io with details for reproducing this issue, and we’ll check it (please send only the link, without login and password). You can create a temporary access link using this plugin: Temporary Login Without Password – WordPress plugin | WordPress.org.

Hi,

I think you are sending me this automatic email because the temporary access has expired. Because I don’t really see what more details I can send you for reproducing this issue. How could we communicate faster than one email per day? However, I try for my part to respond within the hour.
Thanks

1 Like

Hi,

We checked this issue from our side, and it seems okay. We created a “test” listing on your website and blocked the dates; everything seems to be working correctly. Please check this listing. Also, try to create a new listing and test it.

Hi,
you say “it seems okay” but I am doing the test right now by reusing your test listing and also by creating a new listing and the problem is still the same. What test did you do exactly? I think you locked it day by day, and not every day of the week at once.
Did you watch my video? I’m not sure you understand the problem: multiple selection of slot and day with a click and drag and locking with the padlock. Maybe you should ask to Ihor?

Hi,

Please note that we tested it step by step, as shown in your screencast. The test was done on your site, so it’s most likely caching on your end, as everything works correctly after our tests.

Hi,

No it’s not a cache problem, tested from different PCs, especially in private browsing (incognito) and the problem remains the same. (As a reminder, no cache plugin in the testing environment). Even customers report this problem to us. Obviously the dates are not blocked in the same way between you and us. Please also send me a screencast so that I can see how you block the dates from your support account with the “test” announcement.

Hi,

As I have already answered you in previous messages, we block the dates in the same way as shown in your screencast, and also note that we do this on your site when creating a test listing. Unfortunately, I can’t tell you why these dates are not blocked on your end, as I can’t reproduce the issue on your site, nor locally on our sites.