Booking an appointment redirects to homepage instead of Woocommerce Checkout

When I select a listing to book, it goes to the homepage and the path is: /?listing=188&_dates=2022-09-27&_time%5B%5D=68400

But what I would expect is to go to checkout.

Based on other topics in this community, I have already ascertained that:

  • Marketplace and Woocommerce are both active.
  • Woocommerce has created products for all listings.
  • WooCommerce has created pages (Checkout, Shop, Cart)
  • I double checked the listing I was testing, and alle necessary data has been entered (e.g., price, booking slot duration)

Is there anything else I could check to fix this?

Please try refreshing permalinks in Dashoboard>Settings>Permalinks; select any structure with the %postname% in it.

Hi Yana, thank you for your help. I changed the permalink structure to /%postname%/ but it did not work. Now the only page that works is the homepage, all the weblinks to the other webpages generate a 404 error.

Seemed to be a server issue. I use OpenLiteSpeed and this helped me to fix it.

And now it works! Thank you!

1 Like

Thanks for sharing! I recommend selecting one of the available structures without entering it manually; there are a few structures with %postname%.