Can't accept terms when processing Stripe

When trying to test Stripe payments, get error about accepting Terms but there is no checkbox to do so.

Steps to reproduce

Try to pay for an order and hit ‘place order’

Actual result

Can’t proceed/pay for order as error message appears " * Please read and accept the terms and conditions to proceed with your order."

Expected result

Checkbox at bottom agreeing/confirming read and accept privacy and term of use, then clicking place order would process the order.

Extra details


Please try to set page for Terms and conditions page option in Appearance/Customize/WooCommerce/Checkout. Then checkbox should appear on the checkout page

Thanks, I already had this set unfortunately, so it still doesn’t seem to show up:

Please disable third-party plugins and customizations (if there are any) and check if this issue persists. If you use a caching plugin, make sure that caching is disabled for logged-in users

If the issue persists then please send temporary WP access to support@hivepress.io with details for reproducing this issue and we’ll check it. You can create a temporary access link using this plugin Temporary Login Without Password – WordPress plugin | WordPress.org

Thanks, have tried but to no avail. Sending access now!

Hi team, an update: we got Stripe to process only when REMOVING a terms page from the customize settings, but of course we want to have that checkbox and agreement somehow:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.