Defer js makes the Google Map disappear

Describe the issue in as much detail as possible. Please remove the sections below if the issue is obvious enough and doesn’t require extra details.

Steps to reproduce

defer js on Litespeed cache than you explain on How to Speed up a Directory or Marketplace Website Built with HivePress | HivePress Blog

Actual result

Map Google disappear on listing

Expected result

need to have the map appear with deferer js. website very slow, need to deferer in more!

Extra details

Thanks for the detailed report, we plan to update Geolocation this week and fix this issue

1 Like

Ok nice, and I want to buy your plugins: statistics, hourly and Google connection (sorry I’ve forget the real name in english :smile:), but my metrixs are so bad! Do you know if I install it I loose again more time or your plugins are lite? I’m afraid when I see stats…

Sure, you can consider using these extensions of Social Login, Opening Hours and Statistics are required for your site. Statistics one requires integration with Google Analytics, it shows the listing visitor stats to the vendors. We tried to make the extensions as lightweight as possible so they shouldn’t slow down the site.

Hello, I have the same problem, the geolocation worked fine but in the last update it stopped working, the location does not appear, Google API and password are loaded, but it still does not work, can you help me?

Thank you for reporting it. This issue is confirmed reported and will be fixed as soon as possible

Pudieron resolver problema de Geolocation ?? yo instale la nueva version pero sigue el problema

Please send temporary WP access via email to with a link to this topic and any extra details that may help detect this issue, and we’ll check it. You can send a temporary admin access link using this plugin Temporary Login Without Password – WordPress plugin |

Same for me, I updated the geolocation but impossible to delay the JS loading without the map disappearing

Yes, there’s still an issue remaining with deferring Google Maps, please consider disabling this for now (the minify/combine option should be ok though).

yes minify and combine work done, no problem. You know when this problem of defer was repaired?

It’ll most likely be fixed this week, we already made this change locally but it requires a bit more testing.

Hi, I’ve update the geolocation plugin for know if you repare the deffer JS problem. Now I’ve the map but with problem message: “This page can’t load Google Maps correctly.”

I join you a screen for see my setting on litespeed cache and the result on my website. could you tell me if i made a wrong setting.

Thank you

Please check if you have correctly set up and put the Google Maps API key on your website. Here is the tutorial How to get a Google Maps API key - HivePress Help Center

Also, this error message can appear if the credit card linked to the Google Maps API account is invalid or the number of free map views is surpassed. Please check it in your Google Map API account

the API key is correctly programmed and installed and there is credit remaining.

Everything works fine when I disable differ JS functions and combine external and inline JS!

Do you want access to the site to check where the problem comes from?

Please disable the “Combine external and inline JS” option, external JS should be loaded separately because maps accept the API key as a URL parameter, and when JS scripts are combined into a single one all the parameters are removed.

Ok I try it. Thank you :pray:

Work good. Perfect @ihor

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.