Disable comment at blog

I did disable to leave a comment but under my blog the option is always showing leave a comment.
How can i disable this?

I did uncheck 'Allow people to submit comments on new posts and I did also uncheck the option on the page blog. but the comment field is visable all the time


Please make sure you disable Allow people to submit comments on new posts in WP Dashboard > Settings > Discussion, and disable Allow comments in WP Dashboard > Posts.

If the leave a comment form is still displayed, please try disabling the cache for logged-in users and clearing it.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.