Filter Function Not Displaying on Sidebar

Dear Support Team,

I hope this message finds you well. I am writing to bring to your attention an issue I am currently experiencing with the filter function on the sidebar.

Despite having multiple attributes set to display, the filter function is not showing on the sidebar as expected. This problem is hindering my ability to efficiently navigate and filter information within the application.

Here are the details of the issue:

Issue Description:
The filter function is not visible on the sidebar, even though multiple attributes have been configured to show up.

Steps Taken:

  1. Checked and confirmed that the necessary attributes are set to display in the filter.
  2. Verified that the user account has the appropriate permissions to view and use the filter function.
  3. Refreshed the page multiple times to see if the issue persists.
  4. Cleared browser cache to ensure that it is not a local caching issue.

Expected Behaviour:
The filter function should be visible on the sidebar, displaying the attributes set for filtering.

Actual Behaviour:
The filter function is not visible on the sidebar, making it impossible to utilise the filtering features.

This issue is causing a disruption in my workflow, and I kindly request your prompt attention to resolve this matter. If there are any additional steps I can take or if you require further information, please let me know.

I appreciate your assistance in resolving this matter promptly.

Thank you.

Sincerely,
Ryota

Hi,

Please disable third-party plugins and customizations (if there are any) and check if this issue persists. If you use a caching plugin, make sure that caching is disabled for logged-in users. Also, please check that you have not overwritten this template in HivePress > Templates.

​I hope this is helpful to you.

Hi Andrill,

I deleted any third party plugins and have only these five plugins and Loco translate installed and activated. However, the issue still remains the same.
Also, I have no template overriding the setting.

image

Hi,

I see. Make sure that your attributes are not linked to a category in Listings > Attributes > and the categories will be displayed on the right sidebar. If you have them linked to categories, try either unlinking them from categories or selecting a category when searching, then you will see filters.

Hi, is there any way to make them appear on the sidebar when attributes are liked to categories?

Hi,

Unfortunately, this is not possible, the attributes will be displayed only after you select the category to which these attributes are assigned.