Fix the vendor view in listing block from the TaskHive

		return hivepress()->template->merge_blocks(
				'listing_topbar' => [
					'attributes' => [
						'id' => 'vendorprof', // Adds a custom ID

I am using this code to add an ID to the topbar.
and using the css code below to remove it. This isn’t working however.

#vendorprof {
    display: none !important;

Please let me know what you mean about the topbar, if possible send a screenshot or describe this part, there may be a simple CSS snippet that doesn’t require adding a unique ID.

This is the listing block with the template.

This is the listing block without the template.
You see how the styling of the top bar is awful in the template version? I just want to completely remove it. Removing it for the template would remove it also for the normal listing block outside of the template.


Most likely, this is because you have enabled the slider feature for the listing block, try disabling it and then everything will be displayed correctly. Also, if you want to hide it, use this CSS snippet: .hp-vendor–embed-block {display:none}

​I hope this is helpful to you.