Forces user to fill in Required Field from another Listing Category

When importing a select a listing category in this case it’s Viec Lam. However, on the Map Columns screen after selecting the csv file, it forces user to fill in a required field that is from another listing category (Square Feet & Gia). The “Gia” attribute is only applicable to the Sang Tiem listing category and I think should not even show up as an import mapping field when importing under the Viec Lam listing category. It seems the Import Tool is defaulting to forcing user to map all columns from all listing categories which doesn’t make sense as some attributes are only applicable to certain categories.

Upload Screen

Columns Mapping Screen

Attributes Screen for Gia

Thanks for the detailed bug report, the bug is confirmed and we’ll fix it in the next Import update.

Thanks Ihor, in addition attributes that are of type “number” are not importing correctly, even though it’s mapped automatically on the Mapping Screen, it doesn’t pull in the number value after it’s imported. Example of “thunhap” column below.


We checked this issue from our side, and it seems okay.

Please check your attribute; you may have specified its maximum value in the settings, which may be the reason.
Also, please try to specify the attribute in one language because in the CSV file, you have English, and the name of the attribute on the site is in another language.

I checked the max value of the attribute “thunhap” in this case, it has no max value set under the Editing Section. As for the diff language, the display name of the attribute is in Vietnamese as “Thu Nhập” but the field name is in English characters to match what’s on the csv import file and the Mapping function correctly maps the columns. Any other ideas why my number attributes are not importing correctly?

Please disable third-party plugins and customizations (if there are any) and check if this issue persists. If you use a caching plugin, please make sure that caching is disabled for logged-in users.

Please try to import the file twice and check if the attribute value is set in the listing. If the issue persists, and if possible, send the sample CSV file to the email, and we will test this file locally. We have tested attribute by your details, and it works correctly

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.