Front End Submission Form ("Add Details" page) button does not work

Hi,

When I tried to submit a listing through the front-end form after adding in all the details, the “submit listing” button responds to hovering but nothing happens when I click it. I’m wondering if this is a bug?

Screen Shot 2022-12-01 at 3.51.17 PM

Hi,

Please refresh the permalink structure in Settings/Permalinks (choose a structure with %postname% if the default one is selected)

Also, please disable third-party plugins and customizations (if there are any) and check if this issue persists. If you use a caching plugin (e.g. LiteSpeed), make sure that caching is disabled for logged-in users.

Thank you. I just refreshed the page, and the form worked. In this case, do you think it’s a caching issue?

Yes, it’s most likely a caching issue, or if you use a third-party theme/plugins this may be a conflict with another JS script. You can try disabling third-party plugins including caching ones and check if this issue persists.

I‘m using WP Rocket, and I noticed that I did have caching turned on for logged-in users. May I ask why this needs to be turned off? Wouldn’t it be a nice feature if I had content on my website that’s for subscribers only?

Since logged-in users often have different content depending on their role and actions (e.g. extra account pages or buttons, links specific to vendors) caching often causes issues, it works fine for logged-out users since they all see the same website pages. We’ll try to improve integration with caching plugins, but for now it’s better to disable caching for logged-in users and keeping it for logged-out ones. You can still enable minification & merging of JS/CSS files for all users, scripts and styles loaded for users are the same.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.