How can i change the number of ad columns on the main page?

hi, how can i change the number of ad columns on the main page? Thanks

If you mean the home page then please try to edit the home page and here please try to edit the Listings block and change the Columns option

But where I can find it?, how I can do it?

Please open Pages in the WordPress dashboard. Then choose the Home page to edit. Click on the listings block and there will appear a block with settings for the Listing block in the right sidebar Screenshot by Lightshot

As you can see on the screenshot there is a Columns option which is possible to edit to change the number of columns for listing on the home page

Hello!

Do you know what file can I edit to edit the home page on ListingHive? I looked around the directories, but it wasn’t clear. I know how to edit PHP a bit and I want to make 2 rows of 4 columns and it looks like I can only have 1 row of 4 columns max of categories on the home page by default. Thanks!

Edit: I can see it has something to do with this file: hivepress/class-listing-categories.php at master · hivepress/hivepress · GitHub

If you set a custom Home page as a front page in Settings/Reading then there’s no specific file, this page shows any custom content you add to the editor in WordPress/Pages. For example, if you added the Listing Categories block it’ll display a few categories, it’s the same with Listings, Vendors, etc. or any other blocks you add. Please describe the required changes if you want to change some specific elements, e.g. the listing category titles.

Hello!

Thank you for your reply! Sure, so the default home page on ListingHive is great. But, right now the categories or “Top Categories” have a maximum of 1 row showing 4 categories.

I would love to change the maximum # of rows. Maybe 2 or 3 rows.

This can be done actually for the listings. The listings can be multiple rows on the home page.

Where can I edit a file to change this? The file that may be possible to edit so far I have found is here:

I am just working out what edits to make. Thank you!

If it’s a Listing Categories block added to the Home page content, please edit this page in Dashboard>Pages, click on the Listing Categories block and change the number of columns in the block settings (on the right). You can select 1-4 columns for this block.

Hi there @yana … Yep, I saw that, however here is the issue:

right now the categories or “Top Categories” have a maximum of 1 row showing 4 categories.

I would love to change the maximum # of rows. Maybe 2 or 3 rows.

This can be done actually for the listings. The listings can be multiple rows on the home page.

Where can I edit a file to change this? The file that may be possible to edit so far I have found is here: https://github.com/hivepress/hivepress/blob/master/includes/blocks/class-listing-categories.php

I am just working out what edits to make. Thank you!

You don’t have to edit any code for this; e.g., if you set 4 columns and set the number to 8 in the block settings for the Listing Categories block on the home page, there will be 2 rows with 4 columns, 3 rows if you set the number to 12, etc. It works in the same way for the Listings block.

@yana No actually I tried that. If you set it to 8 and 4 … it still shows only 1 row of 4. I have 8 categories. Definitely not working unfortunately.

It seems to work when tested locally Screenshot by Lightshot. Please make sure that there are 4+ categories. If you set the number in the block settings to 8 and some categories don’t appear, try re-saving them; it may be a caching issue.

@yana Thank you for the reply. Here is a under 1 min video demonstrating the problem. When I refresh the page here, I am clearing the cache. I do not have this problem with listings, new rows are created. Only with categories:

EDIT: Re-saving the categories does indeed fix the problem.

Thank you!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.