I can see data in my google analytics but not in statistics

Please note that Google Analytics has updated to Google Analytics 4, which is becoming required to be set up after 1st July 2023

There are just several changes to integrating Google Analytics with HivePress Statistics.

As before, you should set it up in Google Cloud Console. Here is the instruction How to enable Google APIs - HivePress Help Center. But now, it is needed to enable Google Analytics Data API.

To set up Google Analytics 4 on your website, please check this tutorial [GA4] Set up Analytics for a CMS-hosted website - Analytics Help

After creating a property in Google Analytics, please copy the Measurement ID and Property ID in Google Analytics and put them into the relevant fields in HivePress/Settings/Integrations.

Also, there is general information about Google Analytics 4, which can be helpful for you [GA4] Introducing the next generation of Analytics, Google Analytics 4 - Analytics Help.

Additionally, please check if you have the latest version of the extension, if not, please update and see if the issue still exists.

ok thanks

Hi Yevhen,
I tried following your advice regarding the issue, but unfortunately, it did not work for me. I am still experiencing the same problem.

Hi,

Please provide more details regarding this issue (e.g., your actions step by step with screenshots, etc.). This will help us to reproduce and resolve the issue faster.

I see what you mean. I wiped everything and began from the beginning, but the problem persists. I have data in my analytics account and Sitekit on the backend, yet the vendors’ statistics section remains empty.

Another thing to ask is whether it’s right to copy the Property ID into the View ID or the Stream ID?
Screenshot 2023-08-12 115729

Hi,

Please check if you have updated the Statistics extension to the latest version, you should have version 1.1.0

1 Like

I have the same problem… Plugin version is 1.1.0.



Is there solution?

Please make sure that after updating you revoked and then granted Google Analytics access in HivePress/Settings/Integrations/Google Analytics, also setting new GA4 property ID and measurement ID (if you want to also add the tracking code). Please ignore the notice at the top, there’s a minor bug that always shows this notice but it doesn’t affect the new GA4 functionality.

I did it few times but still no statistics:(
Am I the only one who has this problem?

Mine is also not working, even after setting up the new G4 property & following the steps.

Hi,

I’ve just resolved the same issue on another website, and the reason was:

Google Analytics Data API has not been used in project 623857236848 before or it is disabled. Enable it by visiting https://console.developers.google.com/apis/api/analyticsdata.googleapis.com/overview?project=623857236848 then retry. If you enabled this API recently, wait a few minutes for the action to propagate to our systems and retry.

You can check if this API is enabled for the credentials you created in the Google API Console, maybe this is also a reason.

I believe this will be useful to you.

2 Likes

Thank you, Andrii!
It was the reason. Now it works! :+1:

I was also missing that step, as the page was kind of hidden. Thanks Andrii!

Strange, I can’t get it working either.

  • Enabled Data API and I can see API requests in the Dashboard
  • Re-authenticted with Google
  • Tried using optional Measurement ID and Property ID and without

(I use Woocommerce Analytics plugin and insert the gtag manually via cookie plugin though, seems like there are two Tag Manager URLs being printed in the HTML, is that an issue?)

If I don’t provie Property ID and Measurement ID, I don’t see the statistics icon next to the listing.

I also get “Unverified App” warning when authenticating with Google.

Hi,

Please note that we are discussing the configuration of the Statistics extension here, if you need to configure WooCommerce Analytics, I recommend that you refer to their support or documentation.

No, I’m referring to Hivepress Statistics only. The “Woocomerce Analytics” mention was just a side info, namely, that I i also have this installed and if it causes any conflicts with Hivepress Statistics, as there are mutiple tags loaded in the source code.

Fact is, that I don’t get any data in the graphs whatsoever.

No data:

Settings:

Analytics Data API requests working:

O-Auth Client has Rights

Hi,

Please check if you have the latest version of the extension, if not, please update and see if the issue still exists.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.