Image is not getting removed

I added two images in a listing then later I removed the one image. Still both images are appearing in the front end as well as from the backend, which means the image is not removed. It is still there. How to solve this issue?

Please disable third-party plugins and customizations (if there are any) and check if this issue persists. If you use a caching plugin (e.g. LiteSpeed), make sure that caching is disabled for logged-in users.

Also, please try to purge all website cache as it seems like a cache issue

There is no cache plugin. I purged the Cloudflare cache but the problem continues.

I am unable to delete images even from the backend as an admin.

Please send temporary WP access via email to support@hivepress.io with a link to this topic and any extra details that may help detect this issue, and we’ll check it. You can send a temporary admin access link using this plugin Temporary Login Without Password – WordPress plugin | WordPress.org

Ok, The problem was with my hosting. I changed my hosting and it is working fine now.

Same happened for me only on Android

If you mean deleting an image this shouldn’t depend on the OS or browser, the deletion request is sent to the server - please make sure that the current user previously uploaded this image because users can’t delete other’s media.

The problem is only on Android devices with Chrome browser. When vendors trying with same user on save device but with Firefox Mozilla or Microsoft Edge browser thats work fine and they can delete images.

Thanks for the detailed report, we added this to the bug tracker.

1 Like