Image Issues with thumbnails

Hello @ihor and team,

we have the following issue: images for a listing are uploaded but does not preview thumbnail in listing search. We have only two of over hundred listings which have this issue.

## Steps to reproduce
Upload images. Save listing. Images are shown on listing but not on the listing search

## Actual result
Images are shown on listing itself but not on the listing search thumbnail.

## Expected result
Correct display of thumbnail on the search page.

## Extra details
We have disabled cache plugins, used regenerate thumbnails, changed media sizes of landscape small to 400 x 300 px according to all resources on Hivepress. We have re-uploaded from front-end and backend.

Important Note: this happened after duplicating a listing. We only have two listing with this issue

Please advise us what could be done.

Unfortunately, we can not reproduce this issue locally. Please send more details that may help to detect or reproduce this issue (e.g., a link to your site, screenshots, how do you make the duplicate of the listing, have you re-save the listing which you have duplicated or the error message you get).

Please excuse, I wasn’t clear enough. Hope this helps:

1. Step: Duplicate an existing listing on rental hive.
2. Step: delete the images of this duplicated listing. Result: the images of the original also gets deleted.
3. Step: when trying to re-upload images, some duplicates do not generate a thumbnail for the search page. Example: image. Note: all images are uploaded on the listing itself. The issue is only regarding the thumbnail on the search page.

Additional info:
Here are some error messages regarding the thumbnail
Thumbnail issue
: This image is too small for its container. For best results, set the image size to 359 x 269px.

Sidenote: one problem is that there are reviews on the listing. If there is a way to assign the reviews to a another listing please let me know.

Thanks for reporting this, the bug is confirmed, and we will check the possibility of fixing it

But it was impossible to reproduce the issue in step 3. If you use a caching plugin, please make sure that caching is disabled for logged-in users or please try to purge the cache on your website

1 Like

Thank you @yevhen ! Glad you were able to reproduce Step 1 - 2. Regarding Step 3: I have tried to purge all cash, disabling it for logged-in users was already set. Have disabled LiteSpeed. Unfortunately no positive change so far.

Thank you for the details. As a temporary solution please create a new listing instead of duplicating the old one. We will check the possibility of fixing it as soon as possible

Thank you!

This is a bit tricky since the listing has several reviews that have to move with the duplicate. If there is a way to assign the reviews to the duplicated listing, please share.

Thanks!

Please try editing reviews in WordPress/Comments, if I remember correctly WordPress allows re-assigning comments (reviews are basically comments with an extra Rating field) to another post (listing is a custom post type).

Hello @ihor,

thank you for the reply. We couldn’t solve it with WP. I used the Move/Copy comment plugin with no positive results. We also let the client create a new listing - the client wished to keep the old listing as it shows the comments appropriately.

Please let me know if this bug is considered to be solved.

I recommend testing a few “duplicate post” plugins, some of them should also copy the assigned comments. If you duplicate comments, it’s important to keep 2 fields: comment_post_ID (links a review to the listing) and user_id (links the review to the user). Unfortunately there’s no other way to resolve this because it’s rather a missing functionality of the “duplicate post” plugins if they copy the post without assigned comments (at least optionally), HivePress itself stores comments correctly according to the WP database structure.