Single Pages Restriction Request

Hi

I’ve activated the request Single Pages restriction to not be accessible if the user doesn’t have a membership and I’ve created a regular user account to test it, but I can still access the pages. Is there anything else to do other than activate the restriction in the Hivepress > Settings > Memberships > Restrictions > Requests = Single Pages?

Thank you

Please let me know if you tried to access regular pages from WordPress/Pages or the request pages (those in WordPress/Requests)? Also, please note that admins don’t have any restrictions so I recommend testing this with a regular user account.

From the request page with a regular user account.

Also, do you know how I could just remove the checkbox before the extras text on the listing view page?

image

  1. Please send temporary WP access with details to reproduce this issue to support@hivepress.io and I’ll check it.

  2. If you mean making this extra required then hiding the checkbox will not do this, it’ll be unselected by default. We plan to add the “required” option for extras to the next Marketplace version.

  1. Thanks, I received the credentials but without the website URL, please send the credentials via email to support@hivepress.io (not as a reply to the forum email notification, this will not create a new ticket in our system). The easiest way is creating a temporary access link using this plugin Temporary Login Without Password – WordPress plugin | WordPress.org

  2. You can try this CSS snippet, it’ll hide any checkboxes in the purchase form:

.hp-form--listing-buy input[type=checkbox],
.hp-form--listing-buy input[type=checkbox] + span::before,
.hp-form--listing-buy input[type=checkbox] + span::after {display:none!important}