User wants to view order - but gets redirected to homepage

Hi,

we are using Marketplace in combination with Requests. Once a user places an order the request is still active (how can we auto-close it, once an order was placed?) and secondly, once he tries to view his order via /my-account/orders/ it shows the orders correctly but once he clicks on a specific order he gets redirected to the homepage, instead of seeing job details, etc.?

Already deactivated themes and plugins, however, none of this has resolved the issue.

BR

Hi,

Thank you for your feedback. Yes, we are aware of this bug and will try to fix it by the end of the week.

Hi, I am also still struggling with this.

Please indicate when the bug will be fixed?

Hi PGLVS.

Are you still getting this issue?

I am struggling with the same.

Hi,

Yes, please update the Marketplace extension to the latest version 1.3.9

Hi, I am on the latest version. That is where I am picking it up.

I also made sure the order was created after the upgrade.

When clicking on “view order” it directs to “home page”

image

I have also ran Create default WooCommerce pages

Still directing to home page when clicking on “View order”

@marthengbr actually, I also switched back to the temporary fix because the update didn’t work on my end either.

Thanks @PGLVS.

@andrii, please take note of this. It seems like the 1.3.9 update didn’t include the fix for this.

Hi,

After you have updated the Marketplace extension to the latest version, please follow these steps:

Regarding redirecting to the order page:

  1. Please navigate to WP Dashboard > WooCommerce > Status > Tools > and click Create pages opposite Create default WooCommerce pages.
  2. Please refresh permalinks; you can check this doc: How to refresh WordPress permalinks - HivePress Help Center
  3. Also, please make sure you set up payments correctly; you can check this doc How to start accepting payments - HivePress Help Center
  4. If this issue exists, please disable third-party plugins and customizations (if there are any) and check if this issue persists. If you use a caching plugin, ensure that caching is disabled for logged-in users.

Hi @andrii.

I tried all of that and the issue still persists.

Hi,

Please send temporary WP access to support@hivepress.io with details for reproducing this issue, and we’ll check it (please send only the link, without login and password). You can create a temporary access link using this plugin Temporary Login Without Password – WordPress plugin | WordPress.org.

Thanks.

I sent the temp pass.

Hi,

We checked this issue from our side, and it seems okay. Please check your site again (I recommend clearing the cache before testing).

Checked.

It’s working now, Thanks!

Didn’t have to cleat cache.

1 Like

Hey @andrii

It still doesn’t work on our end. I have already sent you a mail regarding this a few days ago.
It would be great if there would be a follow-up on this, to finally resolve the issue.

Thanks

I think if you update the Marketplace extension to the latest version 1.3.9
it solve ur problem, cz HP marktplace doesnot sup HPOS yet, and it happend…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.