Vendor Block Not Working Correctly

Hi. I want to display vendors in a row of 3, but the feature seems to be buggy for me at the moment. Attached below are the pictures of this. As you can see the vendors are crammed too close together here. I’m wondering if there is any solution to the issue. Thank you.


We checked this issue from our side, and it seems okay.

Please disable third-party plugins and customizations (if there are any) and check if this issue persists. If you use a caching plugin, make sure that caching is disabled for logged-in users.

If this issue persists, please send more details that may help to detect or reproduce this issue (e.g. a link to your site, screenshots, a list of installed plugins, or the error message you get).

I deactivated most plugins. That did not change anything. However, when I deactivated my caching plugin, the Vendors block disappeared. I’m not sure what the issue with it is - I do have caching disabled for logged-in users. When I reactivated the caching plugin, the block reappeared, but still incorrectly as it was in my post. Is there any workaround or something else I am not doing correctly?

My site is

Edit: also strangely the issue of sizing does not occur when I do not check the slider option, but I do need it to be a slider.

I wonder if deleting, then reinstalling HivePress blocks (or whichever plugin the Vendor Block is in) would do anything

Please send temporary WP access to with details for reproducing this issue and we’ll check it. You can create a temporary access link using this plugin Temporary Login Without Password – WordPress plugin |

Thank you Ihor. I appreciate the help.


Sorry for the delay.

We checked this issue from our side, which is a cache issue.

After disabling the LiteSpeed plugin, you have another cache (on the server side). If you clear it and disable it for logged-in users, the problem should disappear.

​I hope this is helpful to you.

Hi, I reached out to my hosting provider and had them clear the server cache. Unfortunately that didn’t resolve the issue. May I request a quote from the HivePress team for this issue so you guys could take a deeper look and try to fix it? This doesn’t seem to be server side - perhaps a file was edited somehow.


Sorry for the confusion.

Please disable the slider layout in the block settings if there are 1-3 vendors, I recommend using the slider layout option only if there are enough items to cover the screen width.

It doesn’t seem to be displayed properly. When I use the slider layout, I cannot control the sizing of the vendors profiles, no matter how many vendors are displayed - I tried with 4. However, when I turn the slider off, the sizing works properly. The “column” setting doesn’t seem to work. I’m wondering if it’s possible to completely reset the code for that block because nothing so far has resolved the issue, or if I could request for the HivePress team to work on it. Thank you.


I understand, but this is expected behavior. When the slider option is enabled, the number of columns does not affect anything; it only calculates the screen width. Please consider disabling the slider for now, and when there are six or more vendors in this block, enable the slider.

I see thank you

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.