"You passed an empty string for 'country'. " Error

On stripe payout with vendors I get this error “You passed an empty string for ‘country’. We assume empty values are an attempt to unset a parameter; however ‘country’ cannot be unset. You should remove ‘country’ from your request or supply a non-empty value.”
Found a similar tread in the forum at it was supposed to be fixed in few days, and that’s from last year? any fix for that please let me know.

If you are using an old vendor account, that was created before you enabled stripe connect, you can get to set the country field through the backend.

When enabling payouts through stripe, a new country field is added to the vendor registration, and old profiles doesn’t have this.

Might be your issue

Please let me know if you get this error after the redirect from the Complete Profile form, or by clicking directly on the Stripe Connect link on the account page?

Hey, I didn’t complete my profile properly, now I get "You can only create new accounts if you’ve signed up for Connect, which you can learn how to do at https://stripe.com/docs/connect."
when I click to “Set up payouts on Stripe”
Stripe is activated in the admin side on the test mode and the transaction goes smooth when testing and the users pay vendor, but when vendors try to set up payout, I get this error.

1 Like

Please make sure that you added the Stripe Connect API key in HivePress/Settings/Integrations/Stripe, not a regular Stripe one (used for accepting payments, e.g. in WooCommerce).

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.