Сategory field required when editing a listing

Hello, I cant save edits to a listing because the system says I need to input in the category field - but the field doesn’t show on the edit form so I cant add anything in the field. Meaning I cant save

See the below screenshot:

How do I get the fields to appear

In addition:
Please also confirm if I as the site admin get notified of a listing that has edit changes to be reviewed, and 2.) also when a new listing is added by a host and needs to be approved?

Hi,

Most likely, you added a listing through the backend and did not select a category, so now when editing from the frontend, you are asked to specify a category, as it is required for listing. On the backend side, we use the standard WP UI, so there is an option to not select a category, but we plan to improve this in future updates. I recommend that you also select a category on the backend, and everything will be displayed correctly. Regarding moderation, if it is enabled in HivePress > Settings > Listings, you will be able to moderate all listings after they are created. Also, you will be able to moderate listings if the attribute has the Moderated feature enabled in the Listings > Attributes feature checked, and the vendor has changed this attribute, then you will need to approve the list manually.

​I hope this is helpful to you.

Hey there,

All of these things you mentioned are set up and working properly but still the issue exists. What can I do to make it work?

Hi,

Make sure that you have assigned a category to the listing in WP Dashboard > Listings > Edit listing > on the right sidebar, you can select a category. If the category is selected there, please send temporary WP access to support@hivepress.io with details for reproducing this issue, and we’ll check it (please send only the link, without login and password). You can create a temporary access link using this plugin Temporary Login Without Password – WordPress plugin | WordPress.org.