Change Details on Package Selection not redirecting

I’ve reviewed the other general question about change details not working. I’ve disabled all other third party plugins besides woocommerce, loco translate, and code snippets. I’ve also changed the permalink back to the %postname% option. Please help!

Hi,

Please provide more details regarding this issue (e.g., your actions step by step with screenshots, etc.). This will help us to reproduce and resolve the issue faster.



I’m not sure what else to provide you other than these. If you need something more specific I can get it to you. Just when you press change details it does not go back to the edit listing page.

Hi,

I see. We checked this issue from our side, and it seems okay. Please disable third-party plugins and customizations (if there are any) and check if this issue persists. If you use a caching plugin, make sure that caching is disabled for logged-in users.

Hi Andrii,

I’ve disabled all third party plugins. Don’t have any caching plugins either.
I’m not a huge coding guy (yet) but is there anything wrong with this? Nothing after the “::after”

code

This is also the console error when you press change details. Not sure if this helps at all.

Hi,

Please send temporary WP access to support@hivepress.io with details for reproducing this issue, and we’ll check it (please send only the link, without login and password). You can create a temporary access link using this plugin Temporary Login Without Password – WordPress plugin | WordPress.org.

It’s sent

Hi,

We checked this issue from our side, and it seems okay. For our part, we could not reproduce the issue locally. Please try to check with your hosting provider, they may be blocking such links. Also, if possible, clear the cache on the hosting provider’s side. If the issue still exists after these recommendations, please provide more details, did you customize the theme files directly?

Do you know if this link is coming from your guys’ theme or extension? https://public-api.wordpress.com/wp-admin/rest-proxy/?v=2.0

My hosting provider told me to ask. On top of that, no I have not changed the them files directly, only have added CSS on the additional CSS tab. I’ve also deleted all my additional code and it still doesn’t work.

This photo is what I received from my hosting provider as she was trying to check for bugs. Nothing found but this URL. Not sure how you couldn’t replicate the issue as every person that has tried is getting the same issue.

Hi,

These JS errors are not related to HivePress, it’s related to the WordPress.com hosting provider. The “after” element is ok, it’s used for styling and not related to the link issue for sure.

Please send more details about the issue to help us to reproduce it, I re-tested this locally and the link seems to be ok. Does the page refresh when you click it or there’s no response at all? Also, please make sure that there are no customizations and third-party plugins that may cause this issue, you can try to disable third-party plugins.

Another option is un-publishing the listing attributes in Listings/Attributes and clearing the Title format in HivePress/Settings/Listings section, these may also affect the redirect if not configured correctly. You can publish the attributes back after testing.

Thanks

Unfortunately none of that worked. Is there just a way to recreate the package selection page within the templates section? That way I can just create a back button that works? Essentially the “change details” button is just a back button but seems as though whatever it’s linked to isn’t working.

Sorry for the inconvenience, we have to reproduce the issue in any case to detect its reason, currently it seems to be ok after multiple tests. Please let me know which listing exactly we should test, which browser you’re using and if you have tried a different browser or device, and most importantly a test user account - I recommend registering as a test user and testing the listing process, maybe the issue is specific to your admin account.

Hello Hivepress,

I also have this problem when I log in as a test user. When you hover over the “Change details” link, the url is “/submit-listing/details/?redirect”. I do not know why there is a “?redirect” there. I have deactivated all other plugins except the following:
Hivepress
Paid Listings
Woocommerce
WooPayments

I have made sure that caching is disabled for users (I was using LiteSpeed but I also deactivated that plugin). I assume that any custom code added to the plugins are deactivated when the plugins are deactivated, so I don’t have any more code at the moment for the four plugins shown above. I am using Google Chrome Version 109.0.5414.120.

Hi,

This is the expected behavior since this parameter is needed to avoid skipping the add details step.