Changing user display name to nickname

I’ve looked across the net for this issue but it still persists.
Unsure if this is a Hivepress or WP problem - there’s an option to change “Display name publicly as”, but the option isn’t really an option as it always reverts back to the username.
I’d rather this didn’t happen as blog posts show MY admin username which is not cool, making it easier for hackers.
I could change the author’s name to another vendor’s username but I’d rather fix this.
I’ve altered the vendor username issue with an attribute but not fixed the nickname alternative.
I’ve also tried changing the nicename in MyPHPadmin but no cigar.
I’ve found some PHP code on various forums but none have worked thus far.
I’m using ListingHive for a directory site.
Any help would be appreciated.
Thanx in advance.


Please select the required Display Name format in HivePress>Settings>Users>Display, e.g., you can choose the username, first name, full name, etc. The settings are applied when a user profile is re-saved or if a new one is created.

Hi Andrii,
Thanks for your response but not quite what I’m after.
My issue is within Users>Profile>Name>Display name publicly as
This will change to my nickname but when I save it, it reverts back to username.
This is why I’m curious if this is a WP or HivePress issue

Yes, HivePress overrides default per-profile Display Name settings of WordPress to keep the same format (also for vendor profiles if their names are in sync with user names). Please choose one of the available formats in HivePress/Settings/Users/Display section.