Customise Vendor Page "Nothing Found" message

I have two “related” questions please:

1)
How can I customise the heading “Nothing found” and the text “Sorry, but nothing matched your search terms. Please try again with some different keywords.” on a Vendor page that happens to have to active listing at the time being?

I want to write a more user friendly message such as “Currently there are no active listings for this vendor”

I am afraid that if I try to use LocoTranslate it might also change the text from other pages where I do not want it changed.

2)
If I wanted to temporarily ‘disable’ any Vendor (such as the one above with no listings) to not show in the list of Vendors, without deleting them, how would I go about that?

Thank you for your help!

Hi!

  1. As I know (Andrii, correct me), this message displayed when no listings found, when you search, and when there is no listings for a specified vendor, it using the same string, so if you change this message, this new text will be displayed in that situations.
  2. Go to Wordpress dashboard->Vendors hovering over the vendor name, click on fast edit, search the “status” option, and select “draft”. It will place that vendor profile to draft satus, and became invisible.
    Important! Some plugins (optimizer) will delete your posts or vendors after X days if that in “draft” status, so check it, before you doing this.
1 Like

Thank you for your answer @Fabricator

Re no. 1 - is there any way how to customise this message only when it is displayed on a Vendor page (see example screenshot above?). Perhaps through some snippet?

It is quite a “strange” (non-user friendly) message to display on a Vendor’s page. Instead, I would like to display something on the lines of: “Currenly this vendor has no active listings”.

When a user is using the search or filter function I still want to display the original message “nothing found etc etc”

Can anyone help me achieve this please? Thank you!

Hi! I “h@cked” this for you with css :smile:

.hp_vendor-template-default .hp-no-results p {font-size: 0;}
.hp_vendor-template-default .hp-no-results p:after{content:'Write your very nice message here, and change the font size.'; font-size: 22px; font-weight: bold;}

Insert this css from the front-end customizer, additional css field, and check it is working.

2 Likes

Thank you so much @Fabricator , you’re the best! :slight_smile:

I tried thinkering with the CSS to also change the heading “Nothing found”, but my knowledge of CSS is not there yet :confused:

Would you be so kind to help me a bit more please? Thank you so much!

Yes! Here is it:

.hp_vendor-template-default .hp-no-results h2{font-size: 0px;}
.hp_vendor-template-default .hp-no-results h2:after{content:'Nothing here'; font-size: 26px;}
2 Likes

Thank you so much again @Fabricator - works like a charm :slight_smile: