Disabling default wp-cron.php and set up a system cron job

Hi,
I’m having a problem in my site that hosting quota is exceeded limits, and this seems the reasons:
public_html/index.php and public_html/wp-cron.php.

Therefore, will be a problem in my taskhive website if I disable the default WordPress wp-cron.php and set up a system cron job from the Cpanal in the server that the web hosting provides?

Thanks in advance and if you have any suggestions to solve these two issues, I will be grateful.

Please let me know which limit was exceeded, the database size? We use Action Scheduler instead of the default WordPress cron, it still uses the database for managing jobs but it may have an option for the server-level cron, this requires further research https://actionscheduler.org/

hello Ihor thank you for assistance. No, the database size is fine, but the default WordPress cron exceeded the php excutions in my hosting plan, I apply this solution and so far it seems good. if the problem backed again, I will try use Action Scheduler instead of the default WordPress cron.

How to Replace the WordPress Cron with a Real Cron Job Tutorial - SiteGround Tutorials

1 Like