Incorrect display of the page after login

As we require users to sign in to access the main pages it seems this is tripping up the SEO extension / Yoast when we share the links with users.

Problem: When you are logged in you get the correct snippet as attached, but if the user is not signed on it displays a “user sign in” snippet and no image for the page - HELP!

How can we get the snippet to be consistent whether the page requires sign in or not?


Unfortunately, there is no such option, as this page requires a login, so you can’t preview without logging in.

thanks for getting back to me - can you tell me how I can switch off the need for users to log in to view pages? I can’t seem to find it


Please provide more details on which pages you are referring to, as some of them require a login.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.