Keeps showing uploading even after actually uploading

It keeps showing uploading even after actually uploading on my wordpress form and it shows uploaded* only when i refresh. Hivepress theme

I find same issue on stackoverflow, but topic is deleted .

The only one php error
AH01067: Failed to read FastCGI header, referer: /submit-listing/details/

I log out and login again , this time no problem with the ajax . Making the test few more times i get the issue again . So its not happening every time.
its happening only on submit-listing and never stop loading . If i refresh the page, everything is fine and images are compleatly updated. But i cant expect from users to know that .

Some times i uploud 10 images without issue for less than 1 minute.
Other times 4 images cant be uplouded 10 minutes

php - post max size 256m
image max size 512m
memory limit 512m
execution time 400
max images - 20

Im restarting the appache, but this dosent fix the issue .
Please help

Please let me know if the image itself appears without the page refresh, or both the button is loading and the image is not inserted? If the image is also not inserted, then this may be a PHP settings issue, e.g. if the max_execution_time is passed the script is terminated halfway and even though the file has been uploaded, browser couldn’t wait for the response any longer.

both the button is loading and the image is not inserted

I continue with test and not every time appear php error . Mostly dosent appear

If there’s a specific image we can test locally you can send it and we’ll try to debug this further, but there are no other reports of this issue so it’s probably something related to the server settings and limits.

Its not specific image . I see some same errors reported in google search and some in this forum

https://stackoverflow.com/questions/73473105/it-keeps-showing-uploading-even-after-actually-uploading-on-my-wordpress-form-an

Please let me know if there are specific steps to reproduce this issue, I can’t get the same result on the demo site or locally. The only thing HivePress does is calls the native WordPress function for uploading files wp_handle_upload() | Function | WordPress Developer Resources so the rest depends on the hosting plan, WordPress- and server-level restrictions.

You can also test this with a different hosting provider or plan (I recommend VPS hosting with SSD), in 99% of cases the uploading speed depends on this.

My server is running on Nvme ssd

I click on website from google search → click add listing , then log in from the redirect → back me to details and uploud photos. It dosent bug every time.

Im testing now with disable preload cache

It’s ok if the first step appears as the Sign In page, then there should be a redirect to the Add Details page. If you mean that the Add Details page is refreshed after you fill in all the details then it’s 99% a caching issue.

It dosent redirect. Its just proceed and when i uploud images , not all images was uplouded .

Now i make some changes , and redirect when i fill up the form for log in // only 1st time visit → incognito → log in → fill details for log in > redirect to log in again - > log in 2nd time → add listing ( no issues found to this moment ) , but i need to clear somehow this redirect for 2nd log in

I fix the issue with the double redirect on loged in

But the issue with uploud stil there
Its uplouding 2-3 images if its 4 and stop just loading
If its 7-8 its uploud 6 and “loading”

I add some rules to never cache : /account/(.*)
/account/login/
For custom redirects *( mobile menu )

The issue is only on mobile or i cant reproduce it on desktop, even i make it mobile responsive

If i reload the page everything is fine

Thats the error in the appache log

[Mon Sep 12 ] [proxy_fcgi:error] AH01067: Failed to read FastCGI header, referer: submit-listing/details/

I also add all custom redirections
/submit-listing/category/
/account/messages/
/account/bookings/
/account/settings/

I test everything and its looks like its not caching Issue

However i test ur listinghive demo from my phone and there photos are uplouded for 10 sec - 10 photos
My website take 10 sec + just to uploud 1 image
We are using the same hosting i read it in the forum many times .
Can u please provide me on email with server and application configurations on the demo server and with the image handler so i test it on my live website and see if the issue is fixed

We use the most basic DigitalOcean plan ($5 / month) but this hosting requires at least basic server management skills. If you decide to use it, I recommend their OpenLiteSpeed WordPress installation from the Marketplace.
If you decide to keep the current hosting provider I recommend getting in touch with them because we can’t change anything regarding this on the HivePress end, we just use the native WP function to upload files, the rest is done by WP and the server. For example, the uploading speed may depend on:

  • Other third-party plugins (if they add extra queries on every file upload)
  • Registered image sizes (each size makes WP to generate another thumbnail)
  • Storage type (SSD is much faster)
  • Server settings (script may fail if the execution time is reached, or if there’s an outdated image library it may be slower)

Im also using digital ocean plan

if I don’t inconvenience you, can you send me pictures of MYSQL and server configuration

We use this standard app for creating droplets OpenLiteSpeed WordPress Hosting | DigitalOcean Marketplace 1-Click App I recommend using it because it seems to be much faster than the standard WordPress one. If this issue doesn’t occur on our demo site I recommend switching to this droplet. Alternatively, you can try some managed WP hosting like Kinsta or WPEngine, their support scope is better for WordPress-related issues.

U can check ur server health and application logs
15 minutes ago i make test from Slow mobile 5mb/s Uplloading 10 images 40mb -total on ur demo site and the loading button crash twice .

It’s totally ok since we have a $5 server on the demo and if there’s a slow internet the PHP execution time limit will be reached in any case, the default limit is 30 seconds so if uploading images in bulk took more than this the script will be terminated.

I make thousends of test and debugs.

At the end, If ur on share hosting plan u wont face this issue becouse u use multiple CPU’s for optimizing images, but if ur hosting provider warn u for using too much resources u can make
MAGICK_THREAD_LIMIT= 1 and improve execute time to 300 and max_input_time 300

If ur on cloud or vps thigs are little bit different :
If ur using 1 CPU users with fast internet wont face any issues, at the other hand ppl with slow internet who wants to upload more than 20MB will face " OOM " , OOM is a “server rescuter” who kill 1 random process to dont crash ur server , so if kill child process ( everything’s fine) , but when kill the main process is killing whole upload.
Whatever u make 512 ram uses of ur server or 300 execution time, this never works simply becouse CPU cant handle to make the whole php process for rotation or removing meta from picture and optimize it to 5 different image styles ( if u exclude wp image styles )

Upgrading the server to 4 GB ram and 2 CPU help , if only 1 user with slow Upload speed is uploading in same moment . If they are 2 , OOM killing start again !

We make full debug of plugin , its not plugin issue . Its server one :slight_smile:

Thank you Ihor, if i was listen u at the begining i was going to save 3 days of debuging :slight_smile:

1 Like

Thanks for sharing the testing details! I’m glad this is resolved.