Locate Me option not working

I’ve carefully followed the Geolocation Google Maps API instructions and I believe I set up the Google API successfully.

When someone types in the location area, Google autosuggests and displays options for them.

The only problem is that when someone clicks on the green Geolocate arrow, nothing happens. I’ve tested this in Chrome, Safari and Edge. You can see live here.

Is there something I’m missing?

Hi,
There may be a few reasons:

  • The website uses non-secure HTTP connection
  • Geocoding, Places or Maps JavaScript API is not enabled for the API key
  • Other plugins that load their JS scripts conflict with Geolocation
  • There are code customizations that break the Locate Me script

P.S. Nice customization!

Hey ihor,

Thanks for looking at this. As far as I can tell:

  1. Site loads fully over https://
  2. API key has those 3 parts enabled (see screenshot)
  3. I tried disabling other plugins, didn’t seem to fix it
  4. I tried disabling code snippets, didn’t seem to fix it

It does work in Safari on my phone, but not in any other browsers? Strange.

**Thanks for the design compliments. I’m excited about working with Hivepress.

Please try adding this form to any other sample page, maybe this is specific to the header section. This may also be caused by caching or optimization solutions, e.g. those minifying JS scripts. If this issue persists please send temporary WP access to support@hivepress.io and I’ll try to debug this further.

Hey @ihor,

I tried disabling the Javascript minify but it didn’t seem to make a difference. I created an account with WP access.

Let me know if you need anything else and thanks for your help.

If there was an automatic WordPress email with credentials please also send an email manually with a link to this topic because we get a few WordPress emails with credentials every day. You can also create a temporary access link using this plugin Temporary Login Without Password – WordPress plugin | WordPress.org

Sent. Thanks!