No Google Maps on listings page

Google map doesn’t show on the assigned listings page but does show on the individual listing page.
If I disable the avatar plugin it shows on the assigned listings page. I tried 2 other avatar plugins but the same happened when I activated them.
I need the avatar plugin as it is hard coded in my theme for my membership pages.
I really want to use the hivepress plugin with maps but really need the map on the main page.
Advertisements – Webb Designs plugin enabled, map not showing

Plugin disabled:

Individual listing page doesn’t affect it if avatar plugin is enabled or disabled:

Any help would be appreciated.

I should also mention exactly the same happens with Mapbox.

Sorry, we can’t guarantee compatibility with all the third-party WordPress plugins but you can check the browser JS console (CTRL+Shift+I), maybe there’s a simple JS conflict error that can be fixed.

This morning I found an avatar plugin that doesn’t conflict. All set now.

1 Like

Care to share which one for others future reference? Cheers

One User Avatar. Still have a problem with the map not showing on mobile. It does show on the individual listings. Disabled all plugins and still not working on mobile. It wasn’t showing on individual until I cleared cache. Now it is back. I have cleared all cache, cloudflare, hosting and phone to get it on the main listing page but nothing.
Also can’t figure out regions. I have it set in hivepress and they show in the backend but nothing different shows on the front end. What is it supposed to do? I was hoping for a dropdown to select a region.
Thanks!

1 Like

Figured out a work around that is displaying what I need.
Thanks!

1 Like

Sorry for the delay, if possible share the solution (even a brief description), it may be useful to others.

I used a select list to display in the search form.
I still do not have maps working on mobile on the listing page. This is the main reason I like Hivepress. Displaying the map markers for each location.
Any help for that? Advertisements – Webb Designs

It seems like there is custom CSS customization on your website, which hides the map on the single listing page. This file is in the /uploads/fusion-styles folder on your website, and there is the such a CSS code snippet that hides the map on the single listing page. Please try to remove this code snippet and check if the issue persists

.hp-template--listing-view-page .hp-map {
  display: none;
}

I actually used that css to disable the map on the inside page, not the listing page.
Removing the css as you suggested did not change anything for the listing page.
I cleared all cache and viewed it incognito without the map appearing.
The map is still not displaying on the page.
https://webbspots.com/advertisments/

If you use a caching plugin, make sure that caching is disabled for logged-in users, and please try to purge the cache on your website

Thank you for providing links on your website, but it seems like it works correctly. The map is shown on the single listing page and on the page with the list of listings. Please check these screenshots from the website which you have provided

Did you miss the Mobile part of my question?
Tested on 2 Andriod phones, the map shows up on the initial page load of the page with all the listings. If I refresh the page the map disappears It does show all the time on the single listing page on both phones.
It appears always on the desktop view. If it would stay visible on mobile it would be perfect.

Please let me know if you get the same issue on the demo site https://listinghive.hivepress.io/ If not then this may be related to scripts and plugins specific to your site. Also, please try switching from Google Maps to Mapbox or vice versa depending on which map provider you’re using now, this may help to narrow down the issue.

My theme may be the problem with the maps on my sites. I have tried using 2 different websites with 2 different hosts as test, but both use the Avada Theme. They show up fine on mobile on the demo site.
Thanks for your help.

1 Like