Range filters are not working properly

If you choose far left options - it will show ALL Listings. Why so?


you can see this also in your LIVE DEMO site

UPD: Same happens if you choose far right options

When boundary values are selected in the range (or left unchanged), this means “show all”, so listings with all the values are shown. If some value exceeds the range then this is probably a caching issue, the range should change accordingly if there’s a new listing with the min/max value.

I want to look ONLY all “1 room” (far left option in range) apartments. Why it means “show ALL” ? Its a bug then. Cause it shows 2-3 room apartments too

Or i want to only show all “2023 year” (far right range) apartments. Why its shows 1995 year apartments too? Thats not right

Look at your own demo site. I want to 15 bucks only! Why is shows me 20-25 results? It doesn’t work as it should

Yes, there’s a known minor bug when you select the same values in range (like you selected 15 for min/max), then the filter is ignored - we plan to fix this in the next update. But the issue you described earlier (when you leave the min/max values unchanged on the edges of the range) can’t be reproduced, please make sure that you have no caching plugins that may cause it, also your hosting provider may enable server-side caching.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.