Relationship between HivePress and WordPress profile pictures

Hello,

To optimize my users’ browsing experience, they don’t have direct access to the WordPress dashboard. They manage their profile via the settings in HivePress, where they can add a profile photo. This appears correctly on their user profile. However, when they publish an offer or content, their profile photo is replaced by a generic avatar.

Could you tell me if this problem could be due to the absence of a profile photo in WordPress, or if it’s linked to another cause? And if you have a solution for adding this photo on hivepress and WordPress at the same time.

I’ve been looking for a solution to this problem for three days now, exploring various code snippets and reading numerous topics on this forum, without success.

Thank you in advance for your help.


Bonjour,

Pour optimiser l’expérience de navigation de mes utilisateurs, ils n’ont pas accès directement au tableau de bord WordPress. Ils gèrent leur profil via les réglages dans HivePress, où ils peuvent notamment ajouter une photo de profil. Celle-ci apparaît correctement sur leur profil utilisateur. Cependant, lorsqu’ils publient une offre ou un contenu, leur photo de profil est remplacée par un avatar générique.

Pourriez-vous me dire si ce problème pourrait être dû à l’absence de photo de profil dans WordPress, ou s’il est lié à une autre cause ? Et si vous avez une solution pour que l’ajout de cette photo se fasse sur hivepress et WordPress en même temps.

Je précise que cela fait trois jours que je recherche une solution à ce problème, en explorant divers extraits de code et en lisant de nombreux sujets sur ce forum, sans succès.

Merci d’avance pour votre aide.

Hi,

We checked this issue from our side, and it seems okay. Please provide more details (e.g., your actions step by step with screenshots, etc.). This will help us to reproduce and resolve the issue faster.

P.S. Please post in English (e.g. via Google Translate); this way, questions/answers may also be helpful for others.

Thank you for your feedback.

I encountered this problem using the site-review review system because hivepress review does not currently offer reviews for requests. But I tried with hive-review and the problem is the same.

Users add a profile photo in the settings section of the hivepress dashboard. This appears in the “vendor” profile, but the photo is not displayed when posting offers, the author profile widget when posting ads and in any reviews.
The screenshots can be found above.


Merci pour votre retour .

J’ai rencontré ce problème en utilisant le système d’avis site-review car hivepress review ne propose pas pour l’instant des avis pour les demandes. Mais j’ai essayé avec hive-review le problème est le même.

Les utilisateurs ajoutent une photo de profil dans réglages accessible dans le tableau de bord de hivepress. Celle-ci apparaît dans le profil “vendor” mais la photo ne s’affiche pas lors de la publication d’offres, le profil auteur en widget à la publication d’annonce ainsi que dans les avis quelconques.
Concernant les screens, ils se trouvent plus haut.

Hi,

Please disable third-party plugins and customizations (if there are any) and check if this issue persists. If you use a caching plugin, make sure that caching is disabled for logged-in users. Also, there may be caching on the part of the hosting provider, so we recommend checking the settings.

P.S. Please post in English (e.g. via Google Translate); this way, questions/answers may also be helpful for others.