Remove decimal points in number attributes

I’ve created attribute for stock part number and I’ve selected number for this attribute but when vendors write numbers for value it shows like this 185,004,432 but I don’t want show any point decimals and it shows just numbers 185004432

Please let me know how to remove decimal points

If you use the Number type then numbers will always be formatted (depending on your locale, e.g. comma is used for separating thousands), you can try using Text type instead and set this Regex Pattern:


I want using numbers because I want when vender click on this item only numpad is open

This makes sense, I guess we’ll add an option to disable formatting for the Number type. Please try using the Text attribute as a temporary solution, it will not allow setting non-numbers in any case.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.