Social Login - Doesn't Comply With Google Sign-in Branding Guidelines

Here are the up-to-date branding guidelines, my Outh-app got Rejacted by Google for this…

Hi,

Yes, we are aware of this update from Google, and we will update it from our side in the near future as well. Please use these CSS snippets (How to add custom code snippets - HivePress Help Center):

.hp-social-links__item--google{
	background-color: #FFFFFF !important;
	border-radius: 5px;
	-webkit-box-shadow: 1px 1px 5px 1px #ccc !important;
    box-shadow: 1px 1px 5px 1px #ccc !important;
}

.hp-social-links__item--google:hover{
	background-color: #4285F4 !important;
}

.hp-social-links__item--google span{
	color: #6e6e6e !important;
}

.hp-social-links__item--google:hover span{
	color: #FFFFFF !important;
}

.hp-social-links__item--google img{
	content: url('https://developers.google.com/static/identity/images/g-logo.png');
	height: 30px !important;
}

​I hope this is helpful to you.

1 Like

For a real png logo use this link : ‘https://cdn.freebiesupply.com/logos/large/2x/google-icon-logo-png-transparent.png’

I don’t trust this CDN server, so I will use the original link form Google

Don’t use random CDNs or embed random images in your site!

Oh i’m a beginner thanks for the advice but i modify the code so when the mouse go over the button turns black so I needed a real png image without background. Any clue to make it with a trustful link ?

Snippet not working for me.

Screenshot 2023-09-12 at 21.43.07

Hi. This is not a code snippet (php). Instead it is a CSS code.

Go to appearance>add additional CSS and add this code there.

Hi,

Please check this doc How to add custom code snippets - HivePress Help Center

Thanks for the reply. I’ve done it properly now.

But… when i click log in. I can choose the account. But then it goes to the waiting page, closes, but it doesn’t log in.

How can i fix that?

Hi,

Please disable third-party plugins and customizations (if there are any) and check if this issue persists. If you use a caching plugin, make sure that caching is disabled for logged-in users. Also, please refresh permalinks How to refresh WordPress permalinks - HivePress Help Center