Sort by Attribute not working

I used to be able to sort by attribute, but something has changed in Hivepress in a recent update.

I have a few issues now that I need to get fixed ASAP. Thanks in advance for the help & advice on how to fix these issues.

  1. On Listing-Category Page
    NatureWalk – 3 Bedrooms – RentNatureWalk30A.com

I can no longer Filter on Attributes - in my example Cart/LSV, Private Pool. The radio button does NOT show up anymore. This attribute has Filterable, Indexable, and Sortable all selected. How do I fix this?

  1. On Search by Attribute in the main menu, it no longer sorts by the Attribute. How do I fix this?

The original sort URL that worked was this:
https://rentnaturewalk30a.com/?_sort=&s=&post_type=hp_listing&_category=0&pool=32

This should only be showing homes with Private Pools. Now it shows everything? How can I sort all listings that have an specific attribute (ie. Private Pool)

Hi,

Please disable third-party plugins and customizations (if there are any) and check if this issue persists. If you use a caching plugin, make sure that caching is disabled for logged-in users.

I’ve disabled plugins, and do not use a caching plugin. The problem still exists.

How do I fix this?

Thanks -
Todd

Hi,

We have seen that these two attributes are of type Radio, so I recommend checking their settings (you may have deleted the options for this attribute). Please check them in WP Dashboard > Listings > Attributes > Edit Attribute > Edit Options. Also, the options may disappear if you initially added them and then changed the attribute type to another one.

I believe this will be useful to you.

Thanks, that fixed it! It’s working perfectly now! I’m not sure how/what changed…

Thanks again for your help in finding the right place to look.

1 Like