Unable to search by state & regions

We’re having two separate but related issues, and have tried suggestions from other posts which haven’t worked:

1 - When using the Location search for a city (i.e. Austin), we will get the correct search result, however when using a state (i.e. Texas), no search results display. I’ve tried with both Google and Mapbox and get the same issue in both cases
2 - To get around the first issue, I tried using regions. It’s enabled in settings (Settings>Geolocation>Generate regions from locations), I have both the API and Secret Keys for Google Maps in Integrations and have tried both creating a new listing and updating the location on existing listings, but no regions are created.

I appreciate your help. Thanks

Hi,

Please make sure you set up Geolocation and regions correctly, you can check these docs:

Please note that the Regions feature works only with newly added listings or requests. So, if you have enabled this feature after adding a listing or request location, you need to update your listing or request (i.e., change the current location to any other location, then change it back) and save the changes, then the regions will work correctly

If the regions are still not generated, try setting up a MapBox, as it is simpler, and repeat the steps that generate the regions.

​I hope this is helpful to you.

Thank you for the quick response.

However, I’ve already followed the instructions carefully from both provided links. (I had searched all previous posts on this topic and have gone through those suggestions and the Help Center resources, including trying both Google and Mapbox).

Please let me know what else could be causing this problem.

Also, do you know why I can’t get any search results for a state (i.e. Texas)? If this worked, I wouldn’t need to setup regions.

Hi,

Please go to Listings > Regions, take a screenshot, and send it to us. Also, please provide more details regarding this issue (e.g., your actions step by step with screenshots, etc.). This will help us to reproduce and resolve the issue faster.

Sure. To start here’s a breakdown of the primary issue.

Here’s a screenshot for a location search of ‘Austin, TX’ (a city in Texas):

and then for a location search for ‘Texas’:

The same problem happens for any state search.

Regarding the Regions issue, you can see our settings below:


I didn’t include a screenshot of the integrations page simply because I don’t want to expose my API keys. But both Google Keys have been added. As mentioned, we also tried with Mapbox but are having the same issues.

Please make sure that both API keys are correctly set up, each key should have 3 APIs enabled as described in the docs. The only difference is that the secret key has no HTTP restrictions.

Based on the screenshot, the regions are not generated so it’s either the API keys issue, or there were no new listings since the regions were enabled, or the existing listings weren’t re-saved (regions are generated only when the location is set the first time or changed, to save the API quota).

Hi Ihor,

Yes, the 2 keys are created and configured according to the provided specifications.

As mentioned, the search works for city locations (and the map does as well), however it doesn’t work for state searches…

Hi,

If you have configured the Geolocation extension and regions feature correctly, then there may be several reasons why it doesn’t work:

  1. Third-party plugins.

  2. Custom code.

  3. Restrictions on the part of the hosting provider.

  4. Caching.

Please disable third-party plugins and customizations (if there are any) and check if this issue persists. If you use a caching plugin, ensure that caching is disabled for logged-in users. I also recommend checking the hoster’s settings to see if there are any restrictions.

Hello Andril,

I’ve been troubleshooting this issue for some time and have tried disabling all unnecessary plugins from our staging environment and still have the issue.

I just tested this on your demo site, and noticed the same issue there. Is this a known problem?

Example: On the listinghive demo (https://listinghive.hivepress.io/) if you search for New York City you will get 13 results, however if you search for New York state, there are 0 results:

Hi,

Please try to create a new listing and specify the location, then you will have a generated region and everything should work correctly, I recommend you to review this doc in more detail: How to set up regions - HivePress Help Center

If this issue exists, please send temporary WP access to support@hivepress.io with details for reproducing this issue, and we’ll check it (please send only the link, without login and password). You can create a temporary access link using this plugin: Temporary Login Without Password – WordPress plugin | WordPress.org.

Thanks.
1 - Regarding the Regions issues: I’ll send the temporary WP access shortly.

2 - For the State search issue, can you confirm you guys are aware of the issue? Will there be a fix for this problem?

I see your site still has this issue. I am having the same problem. Was Hivepress able to help resolve?

No, Micali. Unfortunately, we haven’t been able to resolve the issue… I see that Hivepress’ own demo has the same issue.

I’ll keep you posted if we find a solution, meanwhile, please let me know if you do as well.