Vendor cannot delete listing

Hello Hivepress,
I’ve been posting a lot of support requests lately, your plugin is fascinating, and I love it.

I have set up the Paid Listings extension and created a test user, and created a listing with that user. I am also using the Listing Hive theme (great theme by the way).

I’ve discovered that the user cannot delete their listing when they log in. After clicking on the “delete” button, nothing happens. The only thing I see is the URL in the bottom left hand corner turns to [current webpage url]/#listing_delete_modal.

Is this a bug, or have I not activated something? I cannot find anything on allowing or not allowing a user to delete their listings. I’ve tried it with only Hivepress and Woocommerce plugins.

Thank you

Hi,

Please disable third-party plugins and customizations (if there are any) and check if this issue persists. If you use a caching plugin, make sure that caching is disabled for logged-in users. Also, please refresh the permalinks: How to refresh WordPress permalinks - HivePress Help Center

Hello Andrii,

Thanks for your suggestions.
I tried everything you said - I disabled all third party plugins and kept only Hivepress plugins, (this means I also don’t have caching plugins either) and refreshed the permalinks but I still cannot delete listings as a front end user.

Hi,

We checked this issue from our side, and it seems okay. If you are sure that you have done all the recommendations I have described above, we recommend that you also contact your hosting provider, as they may block such requests.

Hello Andrii,

I have tried testing to see if there are any plugins that are causing a conflict that prevents users from deleting their listing, but I cannot find a plugin conflict. I deactivated every single plugin and left only the Hivepress plugin and the Paid Listings extension and users still cannot delete their listings.

I also asked my hosting provider and they cannot see any issues that might be preventing users from deleting things.

What I would like to add is that I think this is a superficial issue because when I click on the “delete” button when logged in as a vendor, a URL shows but it starts with a # hash symbol, meaning the button seems to lead to a HTML anchor on the same page, and not a real function. Then because that item doesn’t exist, nothing happens. The hash symbol ID it links to is “#listing_delete_modal”.

Thanks for the details, if there’s a # symbol added to the URL when you click the Delete Listing link then it’s most likely a JS issue, there may be a JS error caused by the plugin conflict or other reasons. If possible send a link to your site, or you can check the JS error console while clicking the link and copy the error messages here Using the DevTools Console in Google Chrome to Identify Errors

Also, please make sure that the author of the listing has at least Contributor role in WordPress/Users section, this also may be a reason.

Hello Ihor,

The URL is http://amazingadventures.travel/, this is a test site only. Do you also require log in access to the back end?

Also, I set my own user roles and do not have the role “Contributor”. I deleted all the default roles like Subscriber as well, could that be the reason?

If so I will have to reset everything by deleting the site and starting over with a fresh installation (I can do that because this is only a test site).

I am using Version 3.2.9 of the plugin “Members” By “MemberPress”. It lets you edit what capabilities a user role can do. I suppose I should try and grant my custom user role the capability to delete a Hivepress listing? But I don’t know where to find this capabililty and what it is called. Here is a screenshot of the options available to give you an idea:

Hi,

Most likely, this is the reason, because HivePress checks for each popup and form whether the user has the rights to do so. If you have created a custom role, make sure that the user’s vendor has the edit_posts capability in this role, because without it, it will not work.

Thank you Andrii for the suggestion, this was exactly it! I granted my cusotmer user role the ability to edit posts using the Memebers plugin and now they can delete listings!

This is now solved.