When creating a Custom Vendors Template - cannot access Template blocks

I have succesfully created a custom template for the “Listings” page and now I am trying to create a custom template for the “Vendors” page. However, when editing the custom Vendors template, I do not have access to the “Templates” section when choosing blocks, I can only see “HivePress” section. When editing the “Listings” template I can see both Hivepress and Template categories (see screenshot).

Because of this, I am not able to include blocks such as Filter Form, Map and Pagination (which are present in the default vendors template). How can I include these in a custom Vendors template?

Thank you!

Hi,

We checked this issue from our side, and it seems okay. Please provide more details regarding this issue (e.g., your actions step by step with screenshots, etc.). This will help us to reproduce and resolve the issue faster.

Hi Andrii, thank you for your reply.

[EDIT: I created a new Vendors template from scratch and it is now working fine]

I created a template and chose “Vendors” as the base template. At first I could add the ‘template’ related blocks, but as soon as I saved or published my custom template I noticed the following:

  1. The base template reverted from “Vendors” to null (see green circle in attachment)
  2. The template-related blocks that I had managed to add no longer worked and instead I got messages such as the following:

Your site doesn’t include support for the “hivepress/vendor-filter-container” block. You can leave this block intact or remove it entirely.

Any idea what I might be doing (or what is going) wrong please?

[EDIT: I created a new Vendors template from scratch and it is now working fine]

Hi,

Please disable third-party plugins and customizations (if there are any) and check if this issue persists. If you use a caching plugin, make sure that caching is disabled for logged-in users.