When Registering no email is being sent to confirm Registration

Total newbie to Rental Hive (and not that familiar with Woocommerce) here so a bit confused on a few things. One issue I have encountered is that when I test register as a user or vendor (list property) and enter an email and password on the registration page (after selecting register) no email is sent to that address to confirm the registration.The next odd thing is that even though a registration confirmation email doesn’t arrive at the email address I have used to register with when I haven’t confirmed the registration the registration exists on the site and I can login without confirming (because no confirmation email was sent relevant to email address and password). What could possibly be causing this??? In the meantime the site sends a confirmation of booking or cancellation of booking email out so the issue does not appear to be server side but related to the theme register as user feature. Also put the site in debug mode and a bunch of issues showed up. Totally confused as to what could possibly be causing this and switched off plugins to see if anything would change (no luck with that). What worries me the most is that no way should I be allowed to login when I haven’t received and responded to the confirm registration email. Please advise.

BTW this is what is showing in debug mode in the admin

Deprecated : Creation of dynamic property TPAPI_Actions::$params is deprecated in /home/customer/www/indobookings.com/public_html/wp-content/plugins/trustpulse-api/TPAPI/Actions.php on line 54

Deprecated : Creation of dynamic property TPAPI_AdminPage::$params is deprecated in /home/customer/www/indobookings.com/public_html/wp-content/plugins/trustpulse-api/TPAPI/AdminPage.php on line 64

Deprecated : Creation of dynamic property TPAPI::$admin_page is deprecated in /home/customer/www/indobookings.com/public_html/wp-content/plugins/trustpulse-api/trustpulse.php on line 233

Deprecated : strpos(): Passing null to parameter #1 ($haystack) of type string is deprecated in /home/customer/www/indobookings.com/public_html/wp-includes/functions.php on line 7291

Deprecated : str_replace(): Passing null to parameter #3 ($subject) of type array|string is deprecated in /home/customer/www/indobookings.com/public_html/wp-includes/functions.php on line 2187

Deprecated : strpos(): Passing null to parameter #1 ($haystack) of type string is deprecated in /home/customer/www/indobookings.com/public_html/wp-includes/functions.php on line 7291

Deprecated : str_replace(): Passing null to parameter #3 ($subject) of type array|string is deprecated in /home/customer/www/indobookings.com/public_html/wp-includes/functions.php on line 2187

Deprecated : strpos(): Passing null to parameter #1 ($haystack) of type string is deprecated in /home/customer/www/indobookings.com/public_html/wp-includes/functions.php on line 7291

Deprecated : str_replace(): Passing null to parameter #3 ($subject) of type array|string is deprecated in /home/customer/www/indobookings.com/public_html/wp-includes/functions.php on line 2187

Deprecated : strpos(): Passing null to parameter #1 ($haystack) of type string is deprecated in /home/customer/www/indobookings.com/public_html/wp-includes/functions.php on line 7291

Deprecated : str_replace(): Passing null to parameter #3 ($subject) of type array|string is deprecated in /home/customer/www/indobookings.com/public_html/wp-includes/functions.php on line 2187

I also installed WP Mail SMTP - still no confirmation mail. And without confirmation the email I used for a test to register showed up in the admin, although this time with unverified in red and WP Mail recorded |Event #2|Error|Mailer: Other SMTP SMTP Error: Could not connect to SMTP host.|WP Mail SMTP|July 11, 2024 at 7:24 am|
| — | — | — | — | — |
|Event #1|Error|Mailer: Other SMTP SMTP Error: Could not connect to SMTP host.|WP Mail SMTP|July 11, 2024 at 7:23 am|

Hi,

Please do not post your license on the forum, as it is public, and anyone can use it.

Regarding your issue, please disable third-party plugins and customizations (if there are any) and check if this issue persists. If you use a caching plugin, make sure that caching is disabled for logged-in users. Also, please make sure you set up emails correctly using this doc: How to set up emails - HivePress Help Center

​I hope this is helpful to you.

Oh sorry I saw posts where admins said if you posted your user number we would get back to you quicker. No probs won’t post that again. Okay done all the standard things bar cache. Siteground who is my hosting provider has an onboard cache so how do I get around this? I just noticed that siteground can exclude URLs from caching - what urls should I exclude please?

Hi,

I would recommend you to contact their support or review their documentation, as we are not familiar with this service. They should provide you with more detailed information.

1 Like

Thanks, after a lot of trial and error I got it operational and yes reading the documentation.