Add Listing goes to 'complete profile' and not 'submit listing'

When I try to test the listing process as a site user/subscriber and click on the ‘add listing’ button it takes me to complete my profile which has already been completed. I click submit and it just stays on that page - /submit-listing/profile. It also doesn’t redirect to the form when I try to go through selecting a package to submit a form. Where can I find the submit listing form template? What am I missing?

1 Like

I am also having this problem. If anyone knows about it I’d appreciate it!

If the Complete Profile page appears this means that at least 1 required vendor profile field is not set (e.g. it can be the vendor category if you added at least 1 category in Vendors/Categories, or if you added a custom code snippet to make some fields required). You can also try to disable all third-party plugins and check if this issue persists. If so please send temporary WP access to support@hivepress.io and we’ll check it for you.

1 Like

I am still having this issue. I will send my site info to the support email.

I am having the same issue. It is rather frustrating. Trying to figure out what is going on now.

I checked your site and the Complete Profile step appears in the listing process because you added required vendor attributes in Vendors/Attributes (for example, Registry) and also enabled Location for vendors in HivePress/Settings/Geolocation (so the required Location field is also added to the vendor profile form).

If there’s at least 1 required field without a value, the Complete Profile step appears before the Add Details step in the listing process, to prevent adding a listing if vendors haven’t completed their profile details yet. The listing process is not broken, if you fill the required profile details and submit the form you’ll be redirected to the next step (Add Details) and add a listing.

If you don’t want to require details like Registry before a vendor adds a listing please un-check the Required option for it in Vendors/Attributes, and disable Location field for vendors or make it optional. If there are no required fields, the Complete Profile step will be skipped.

I still have the problem.

The problem does not occur with new accounts. For old accounts I have to add a category. I have previously tested with the seller category and the required location. I deleted the categories and turned off the location, but I still have a problem. My customer account only has a phone number added and nothing else. I have cleared the cache files. Maybe there is something in the database, but I don’t know where to look for it
I have the latest version of the files.

The only condition for the Complete Profile step to appear is if the current vendor has at least 1 required field that’s not set. This may occur if you added a custom code snippet (e.g. the one that makes the First Name required) or added a required vendor attribute in Vendors/Attributes section. Also, this page may remain even after removing customizations/attributes if your website is cached (e.g. using a caching plugin).