Booking payments message “something wrong”

Hello,

I have the same problem as in the two posts below.

I have also checked everything mentioned there (Woocomerce default pages, listing updated, WooCommerce product has been created automatically).
The HivePress Stripe integration is used for payment/payout.

I have also reinstalled WooCommerce, but the problem persists.
In the Apach error log an error 500 GET /account/bookings/288/pay/ HTTP/1.0 is always logged when trying to start the payment process.

Hi,

Regarding redirecting to the payment page:

  1. Please navigate to WP Dashboard > WooCommerce > Status > Tools > and click Create pages opposite Create default WooCommerce pages.
  2. ​Please edit this listing (either on the front-end or back-end) and re-save it, setting the Price. This should generate a hidden product for a listing (or package\request), and the checkout redirect should be okay.
  3. Please refresh permalinks; you can check this doc: How to refresh WordPress permalinks - HivePress Help Center
  4. Also, please make sure you set up payments correctly; you can check this doc How to start accepting payments - HivePress Help Center
  5. If this issue exists, please disable third-party plugins and customizations (if there are any) and check if this issue persists. If you use a caching plugin, ensure that caching is disabled for logged-in users.

​I hope this is helpful to you.

Hallo andrii,

i had already verified and applied points 1-3 before posting here, as these suggestions have been repeatedly mentioned in the forum.

As for point 4, I hadn’t set up a payment method in WooCommerce because I assumed it would function with Stripe Connect activated in HivePress.
However, I have now installed the “WooCommerce Stripe Payment Gateway” plugin and connected it to the Stripe account intended for payouts and have activated the payment method Direct bank transfer integrated in WooCommerce for testing. But nothing has changed in terms of behavior, it still doesn’t work.

The issue persists regardless of whether third-party plugins are activated or not. I don’t have any caching plugins installed, nor have I made any customizations.

Every time I click on “Proceed to Payment” or “Pay” (under My Account > Bookings), I encounter the same problem.

image

Hi,

Please send temporary WP access to support@hivepress.io with details for reproducing this issue, and we’ll check it (please send only the link, without login and password). You can create a temporary access link using this plugin Temporary Login Without Password – WordPress plugin | WordPress.org.

Hi,

We checked this issue from our side, and it seems okay. Please review your site and make sure everything is working correctly.

I was able to make a test booking. However, 2 out of 2 available articles were booked and there was no selection of how many you want to book. Only the date selection.
And at the end there was an error message saying “No Listing found”.

Bildschirmfoto vom 2024-05-21 11-10-10

The order was displayed as “confirmed” in the seller view and “processing” in the backend.

The buyer had two orders in his account. One was “confirmed” and the second was “unpaid”.
The payment was also visible in the Stripe test account. But only for one booking.

I have now canceled all bookings and initiated a refund.

The listing was then “hidden”. I edited it and selected “unhide” and set the quantity to 1 and saved it. Then I tried to make a booking again.

The same error message appeared, which is why I opened the topic here.

Bildschirmfoto vom 2024-05-21 11-52-21

My questions now are:

What did you change so that the first booking I tested worked halfway?
How exactly does WooCommerce have to be set up so that it works with Stripe? Is the way I did it correct?
I find the instructions provided by HivePress a bit lacking. You must have already tested all this and be able to provide a “best practice” on how to accept payments with Stripe and then pay out to the Marketplace sellers via Stripe.

Does it make sense to recreate the WordPress instance? Is there something wrong with the database?

Regards

I have now edited the listing again as a seller and then made another booking with the test buyer and now it has worked as it should.

I will now wait a few days to see how everything works with paying out and refunding the deposit.

If everything works reliably then the problem can be considered solved.

I would still be interested to know what you did to make it work during the first test :smiley:

Hello andrii,

basically the booking and the further payout via stripe seems to work.

But the booking does not always work and these are the things that I have noticed or that I do not fully understand.

1. If you set in WooCommerce that the prices are displayed WITHOUT tax then the total price is displayed correctly when selecting 2 days.

image

image

If you select more than two days, the price is no longer displayed correctly.

image

2. If you set in WooCommerce that the prices are displayed including tax (this is actually correct), the price is displayed WITHOUT VAT when selecting the date.

image

image

And only if the option that the price should be displayed including VAT is active in WooCommerce, the price also appears in the second step of the booking. Then again correctly but only if you select a maximum of two days. In HivePress itself I have had the option “Include taxes in the balance calculations” active from the beginning.

3. The quantity selection does not work

Is this a bug or does it have to do with the quantity available in the listing/item?
I interpreted the quantity to mean that you (in this case a tool) can lend X times because it is available so often.
In the test case currently 2 times.

image

However, the buyer has no choice for the quantity and it seems as if the days you select are allocated to the quantity in the listing. For example, if 2 are available and two days are selected then the booking works. If you select 3 days the booking fails.

This is also displayed in the checkout.

EDIT:

Manual delivery in the seller view for a booking does not work either. If you click on “Deliver” then only “#order_deliver_modal” is added at the top of the address line and nothing else happens.

Hi,

  1. Please note that the correct price is displayed only on the checkout form, and it will contain all the details of what you are paying for. Regarding the calculation, please disable third-party plugins and customizations (if there are any) and check if this issue persists. If you use a caching plugin, make sure that caching is disabled for logged-in users. Also, there may be specific cache settings on the part of the hosting provider, I recommend checking them as well.

  2. Unfortunately, it will not be displayed in this way, as there is no such calculation here, you can view the correct amount only on the checkout form.

  3. Please note that the quantity feature is designed exclusively for the Marketplace, if you have the Bookings extension installed, you need to use the guests feature: How to add guests to bookings - HivePress Help Center

Try disabling the quantity feature, enabling and configuring the guest feature, and following the steps I’ll tell you in the first post. Everything should work without any issues.