Custom attribute not showing up in default search form

I have created a custom attribute and selected all the options for it to show in search. But it still doesn’t appear on the search form on my home page

This problem was reported here Adding attribute to default search form
but there was no solution posted.

FYI I have selected all categories, and also the field type is Select.

My search bar on homepage alone, shows only keyword and categories.

See screenshot
Screenshot 2023-09-12 at 18.38.56


Please disable third-party plugins and customizations (if there are any) and check if this issue persists. If you use a caching plugin, ensure that caching is disabled for logged-in users. If this issue exists, please send a screenshot of all settings of this attribute.


I have disabled the plugins as you said, but it still doesn’t work. The attribute only shows up on the Search bar on the categories page. See screenshots of settings below.


You have restricted this attribute to categories, so it will not be displayed by default, you need to select a category, click search, then it will be displayed in the search.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.