Extremely slow down performance on upload images for listing

After create about ~10 listing with ~20 images, the sites becomes an extremely slow down performance. After restart it will work until about ~10 listing creation.

Any idea?

Please share more details about the issue, do you mean that uploading becomes slow or the whole website (e.g. listing search)? This may be related to the hosting provider, we use the core WordPress functions to upload images.

Yes, only upload images are slow down preventing the listing to be saved. It’s hosted on AWS and the metric is ok (

Please try uploading the same set of images on the theme demo site, if this issue is not reproduced there, it’s related to the hosting plan and/or third-party plugins that slow down the uploading.

The tests was made unsuccessfully… but the error below is showing up. Could you help me please?

image

Please let me know if you tried uploading images on the demo site and the same error occurred? If not then this is probably related to the hosting provider limitations or server settings.

If this issue can be reproduced on the demo site, please let me know how to reproduce it step by step (e.g which images and how many should be tested) and I’ll be able to debug this further.

If you get 503 error in the console you can also check the PHP error log, there will be the detailed error message (with the file name and line number where the uploading fails). It’s most likely a server limitation because this error means that your server stops accepting new uploads for some reason:

A 503 Service Unavailable Error is an HTTP response status code that indicates your web server operates properly, but it can’t handle a request at the moment.

hello ihor,
Yes, absolutely. On demo site, the same behavior is shot:

I’ve enabled the DEBUG and I’m trying to get more information on DEBUG.LOG asap

In my tests, i was unable to generate PHP error log (debug.log). It`s looking like a plugin/hivepress issue. What you think? Could you please help me to debug the situation?

Please provide instructions for reproducing this bug, e.g. how many images you selected, which images should I select, specific formats or file sizes, etc. If it can be reproduced on the demo site we’ll be able to debug this further.

I’ve selected 10 JPG files with ~1.5MB. For last test, I just duplicate files with copy/paste.

Thanks for reporting this, the bug is confirmed and we’ll fix it as soon as possible.

1 Like

hi yevhen, is there a way to track this fix? what is the next steps?

We have to research this further, it’s probably a memory overflow when too many concurrent files are uploaded, maybe adjusting the uploader script will help. I’ll check this as soon as possible.

1 Like

I’ve tested this on the demo and checked the logs, it seems that the uploader hits the server limits:

Reached max children process limit: 10

So this issue is caused by parallel uploading, it should speed up the uploading but only if the server limits are enough. We’ll fix this in the next update by breaking the uploaded files into groups, or replace the current uploader with a new script.

If it’s urgent please try adjusting the server configuration as suggested in this related topic https://groups.google.com/g/jquery-fileupload/c/zKgKBHnYbq0?pli=1