Larger images (taken by a phone) wont upload to listing 504 error

@andrii

I have tried what other forums said on this issue, also disabled 3rd party plugins, cleared cache, different devices, etc. I cant ask user to make images smaller to upload.

I hoping someone can provide better information on how to resolve the issue of uploading images from you phone/larger images to a listing or profile…really any larger images will have issues being uploaded. (ive noticed for sure 5mb wont work).

The image uploaded and submit listing just keep spinning. I can get the image to appear if I refresh the page but it still has a error completely uploading and only appears on the listing page and not within the listing block on main page (featured listing)

Hivepress says its a server issue or wp photo upload issue but it seems to work on their demo site after waiting a little while for them to upload. Hivepress demo site will upload larger files but it takes longer…no idea why mine wont work.

Namecheap says its a Hivepress software theme issue.

Fun everyone is pointing fingers and cant figure it out.

I have seen this issue mentioned multiple times and no one seems to be able to explain what the issue is or how exactly to resolve it.

Thank you for any help any can provide :slight_smile:

Hi,

Please check this topic: Images taking a long time to load

I believe this will be useful to you.

Not helpful, I tried all that. I have tried everything. Were you able to go in and see the php 504 error? The upload picture action wont complete. If I hit refresh after a couple minutes the picture will appear but wont let it upload correctly…it may show on the listing page but not the listing bucket.

I am at a loss, other developers have reviewed, host reviewed and made changes?

No one seems to know or take ownership.

Please help!

Hi,

As I have already informed you in the mail, this is not related to HivePress, so we cannot help with the solution. I recommend watching a tutorial on third-party resources, such as this one: How to Fix the 504 Gateway Timeout Error in WordPress