Payout method does not show

Hi, while requesting a payout on my experthive site, I cannot see the method and therefore I cannot submit a payout request…do you know why this happens?


Please disable third-party plugins and customizations (if there are any) and check if this issue persists. If you use a caching plugin, make sure that caching is disabled for logged-in users.

If this issue exists, please send temporary WP access to with details for reproducing this issue, and we’ll check it (please send only the link, without login and password). You can create a temporary access link using this plugin Temporary Login Without Password – WordPress plugin |


We have checked this issue and you have the Manual payout method selected, but no methods have been created. Please check this doc for more info How to set up payouts - HivePress Help Center

I selected Stripe Connect as a payout, but still, payouts do not work.

This is what happens:

  1. the seller goes to the dashboard and sees the “Set payouts on stripe” button

  2. clicks on the button and then this WordPress error page loads.

what can I do?

Ok I tried to visit de docs about Stripe Connect here: How to enable automated payouts - HivePress Help Center

The fact is that I cannot find the API Key. This is my stripe express homepage and I looked on the account page too but there is no reference to API keys.

Stripe suggests following these steps to find an API Key: Explore Connect | Stripe Documentation

but honestly, it looks like that from a Stripe Express account linked to Woocommerce payments there is no way to do so, I looked everywhere for an API key section but I did not find it.

Any idea on how to generate an API key for Stripe Express and then place it on HivePress?

If anyone from the HivePress team is able to do so I can grant access to my Stripe account, but I desperately need to be able to make sellers get paid on my website


On the HivePress setup side, we can provide information where you need to provide the Stripe Connect key and other data How to enable automated payouts - HivePress Help Center. For other customizations, you’ll need to refer to Stripe’s documentation or their support.
Also, please note, that customization is beyond our support scope - it includes fixing bugs and guidance about the available features Support Policy | HivePress.

Regarding the error you were seeing, it’s because the vendor was registered before you enabled Stripe, and you now need to specify the country for each vendor (a required field on the Stripe side).

Hi. Thanks for clarifying. Anyway, I created another seller account to see if the problem would persist, and unfortunately, it does.

Now when a seller creates an account there is a “proceed to stripe” button to complete the profile,

but after clicking that button, there is a WordPress error page loading. Do you know why this happens?


I recommend checking the settings in more detail, most likely, you have entered the key incorrectly. Please check this doc How to enable automated payouts - HivePress Help Center

Hi, so after a while, I discovered that to find the API key I needed to open a different stripe account (another one) other than the Stripe Express account associated with WooCommerce.

I found my API key and put it on Hivepress>Integrations, and now the error that loads when a seller clicks on “proceed with stripe” has a different text, which is the one you can find on the screenshot:

I reached out to woocommerce and they told me to reach out to you for this issue, do you know how I can fix this?

I guess there’s a misunderstanding regarding the payment gateways, please let me know if you use WooCommerce Payments or this one? WooCommerce Stripe Payment Gateway – WordPress plugin |

If you use WooCommerce Payments you can’t use Stripe Connect for your own marketplace because WooCommerce Payments already works as a marketplace and treat your site as a vendor so they require a Stripe Express account (the same one that you want to require from your vendors). Please use the payment gateway suggested above, then you can use the same Stripe Connect API key, and your vendors will register Express accounts during the onboarding process.

Hi, the fact is that there is no API key on the Stripe Express account. The only way to find an API key is by having a different Stripe Account other than the Express one. I downloaded the WooCommerce Stripe Payment Gateway, and I just need to find a solution to let my vendors open their profiles on my website. Unfortunately, none of this is clearly mentioned in the hivepress documentation. Could anyone from the HivePress staff specify which is the process to insert an API key on “integrations” if not with a regular stripe account? The reason I am asking this is that the Stripe Express account does not have an API key included. Therefore, I opened a different stripe account (regular one not express) and managed to find an API key. But now I have the problem I mentioned before.

Thank you so much for the support

Please check the above instructions again, you have to use the Stripe Connect account, not the Stripe Express one Explore Connect | Stripe Documentation Once you create and setup the Stripe Connect account you’ll be able to copy the API key. Then vendors on your site will create Stripe Express accounts that will be linked to your Stripe Connect account (they will be redirected to the Express onboarding when trying to add a new listing, or if they register directly).

as you can see, and as I said before, I created a new Stripe account (NOT an express one), so it must be a connect account.

I took the Secret API key from there and pasted on HivePress integration, and now I have the problem I mentioned before.

I really need to find a solution this though, I don’t know what might cause the issue :frowning:

The account on the screenshot is not the main Stripe Connect one, it still shows WooCommerce Inc. so it’s a linked account of the WooCommerce platform (WooCommerce Payments). I know this may be confusing but the only thing required in HivePress is the Stripe API key, the rest (docs on how to set up the Stripe Connect account, support regarding this) can be found on the Stripe side. Please contact Stripe Support and tell them that you need a Stripe Connect account, not the Express or Standard one and they will guide you.

Hi, I reached out to Stripe and this is how they replied:

"When you create a Connect account, you’ll be asked to choose a type of account. Your options are Standard, Express and Custom. Creating a Connect account on its own, is not possible. A Connect account is not a stand-alone type. It will always be connected to a platform.

I highly appreciate your perseverance in finding answers to your concern. WooCommerce manages the majority of your connected account’s experience with payments (payout schedules, charge types, etc). They definitely play a big role in this matter."

Since there is no stand-alone Connect account, what do you suggest me to do to solve the issue?

I guess they misunderstood your question, they provided instructions for the “connected” accounts, those are registered if the marketplace platform uses Stripe Connect, for vendors to receive their payouts. Based on the screenshot above, it seems that you registered a connected account for WooCommerce Payments (this service itself acts as a marketplace so they consider you a vendor, while you need to register a Stripe Connect account for your website which acts as a marketplace, for your vendors to register connected accounts and receive their payouts).

Please describe to them that your website is a marketplace itself and you want to use Stripe Connect to accept the initial payments and then make transfers to linked accounts of your vendors (HivePress already implements this, vendors are redirected to Stripe onboarding for connected accounts if you already set up the main Stripe Connect account) - they’ll provide instructions.

When I tested this I simply followed this process Sign Up and Create a Stripe Account | Stripe but if you already have an account connected to another Stripe Connect with the same email you have to use another email, otherwise they’ll simply redirect you to the existing account.

Ok first I will try to open a different stripe connect account with another email and see what happens after using that API Key.Maybe having used the same email to create a different stripe connect account may have caused the issue…

Hi, unfortunately after having created a new account with a different email the issue persists

This is a screenshot of my new account

As you can see there is no mention of WooCommerce here and when I put the new Secret API key the problem did not change. What can I do? I do not think that I have done anything wrong during the process…

Please let me know if you have any suggestions…I really need the automatic payouts to work on my experthive site