Unable to show header image in homepage

I am unable to get the featured images on my homepage.

I followed the steps given in this thread (and the linked YouTube video): Featured Image or Header Image not showing

As far as I understand, the featured images never worked - right from the beginning when I imported the demo on my WordPress.

Here are some screenshots:

Can you please help me here. Thanks!


Please check this doc How to change ExpertHive header images - HivePress Help Center

Hi Andril,

Thanks for the swift reply. I reviewed the video and forums on the same topic multiple times, and followed the steps. It is still not working - I can still not see the header images on my homepage.


Please disable third-party plugins and customizations (if there are any) and check if this issue persists. If you use a caching plugin, make sure that caching is disabled for logged-in users.

If this issue exists, please send temporary WP access to support@hivepress.io with details for reproducing this issue, and we’ll check it (please send only the link, without login and password). You can create a temporary access link using this plugin Temporary Login Without Password – WordPress plugin | WordPress.org.

Hi Andrii,

I have sent the email to support@hivepress.io. Please take a look.

Team Purohit Connect


We have checked this issue, you have changed the images in the header correctly, but you did not specify the Home Page in Settings > Reading.

Now everything seems to be displayed correctly; please check your site.

Thanks a lot Andrii for quick response and correcting the website for us!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.